When Vista gets stuck on the Preparing desktop... screen and then ends up on a blank screen or with an error message, it usually means the drive letter assignments are incorrect. If that's the case, the fix is fairly simple.

Once you get the blank screen or the error message, do the following (it's okay to leave the error message on the screen):
1. Press Ctrl-Alt-Del.
2. Start the Task Manager.
3. Run Explorer (File menu, New Task (Run...), explorer).
4. Once Explorer is running, you can see what drive letters are assigned to your partitions. For example: Your Vista partition should be C:, but is assigned as E:. C: is assigned to a different partition.
5. From Task Manager, run Regedit.
6. Browse to the following key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
7. This will list your drive letter assignments (shown as \DosDevices\C:, for example).
8. Rename the drive letter keys to be correct. For this example, we need to swap E: and C:.
9. Rename the C: key to \DosDevices\E:
10. Rename the incorrect E: key to \DosDevices\C:
11. Exit Regedit and reboot the computer.

This is just an example. Your drive letters will probably be different. However, the Windows partition is usually assigned the C: drive letter. Other drive letters may also be incorrect. They can be fixed using this method or you can fix them using Disk Management after booting into Vista.

Taken from:http://www.wilderssecurity.com/showthread.php?p=1397236
and
http://www.wilderssecurity.com/showpost.php?p=1191656&postcount=71

You can boot from the Vista DVD, start the Repair Mode, start the Command Prompt and then start regedit from the prompt.

From there, you can Load the Hive from the Vista partition and make the necessary changes. You can find similar instructions in this post. In your case, you just want to change D: to C: (I'm assuming) so the Vista partition is correct (you don't want to clear all your MountedDevices entries). Also, though the instructions in the post are for XP, the same instructions apply to Vista.

I went back and reread most of the thread again. I forgot the fact that you had previously put the 500GB drive into a USB enclosure and connected it to another computer (Post #34). Since you have access to another computer with this drive, you can use that instead of BartPE or installing XP again to clear the MountedDevices registry entry. Of course, if you already have BartPE you can use that.

IMPORTANT: If you do this procedure from another installation of Windows, make sure you delete the entries from the loaded hive on the 500GB drive and not the entries from the installed Windows system.

When you get to Step 5 in the list in Post #64, you could do this instead:

1. Put the 500GB drive back into the USB enclosure.
2. Connect it to the other computer (the partitions should show up in My Computer). Make note of which is the "D:" partition. It won't be assigned as D: on the other computer so you'll need to find out what it is. It may be F: or G:, for example.
3. Start regedit.
4. Click on the HKEY_LOCAL_MACHINE key to select it.
5. Click on the File menu and select Load Hive...
6. Select the drive on the 500GB disk that is the "D:" partition. I'll use F: in this example.
7. Browse to the F:\Windows\System32\config folder.
8. Select the system file and click the Open button.
9. A box will come up asking for the Key Name.
10. Type in MyXP_System and click the Ok button.
11. You should now see the MyXP_System entry added to your local registry under the HKEY_LOCAL_MACHINE key. (See Figure A below.)
12. Browse to the MountedDevices entry.
13. Delete all the entries under that key except for (Default). To delete an entry, right-click on it (\DosDevices\C:, for example) and select Delete from the pop-up menu.
14. Unload the Hive by clicking on MyXP_System to highlight it, selecting the File menu and then selecting Unload Hive... Finally, click Yes and then close the registry editor.

Now, put the drive back into the computer and proceed with Step 6.


Page last modified by Neil Herber, February 20, 2009, at 11:43 PM